Service Update: Microsoft Outage

Incident Report for Cetrom

Resolved

This Microsoft issue is now fully resolved.

Thank you for your patience while Microsoft worked to resolve this issue,
Cetrom Support

Please share this information with your team.
Posted Mar 01, 2025 - 21:37 UTC

Identified

Microsoft is troubleshooting the issue you may be experiencing accessing Microsoft Outlook. We will provide an update as soon as we have more information.

Thank you,
Cetrom Support

Please share this information with your team. Outlook.com is unavailable, you can access your email via Spam.cetrom.net.
Posted Mar 01, 2025 - 21:26 UTC
This incident affected: Microsoft 365 (Microsoft Applications).