Service Update: Support Line Issue - Investigating

Incident Report for Cetrom

Resolved

The issue with our phone vendor, which manages our Support Line for technical calls, is now resolved. The Support Phone line is now operating normally.

Thank you for your patience while our phone vendor worked to resolve this issue.
Cetrom Support

Please share this information with your team.
Posted Feb 12, 2026 - 21:09 UTC

Investigating

Our phone vendor, which manages our Support Line for technical calls, is currently experiencing issues affecting our ability to receive and make inbound and outbound calls.

If you are attempting to call in but are unable to reach our support line, please email Support at support@cetrom.net. Our support team can address any questions and troubleshoot through our ticketing system until the third-party phone system issue is resolved.

We will send an update once we have a resolution from our phone vendor.

We thank you for your patience while our phone vendor works to resolve this issue.
Cetrom Support

Please share this information with your team.
Posted Feb 12, 2026 - 20:18 UTC
This incident affected: Cetrom Communication Systems (Phone).