Update: It appears the CCH Axcess outage has been resolved. CCH is reporting that all systems have returned to normal. We have followed up with CCH Support to identify the root cause.
Background: Some CCH clients are reporting slowness with CCH Axcess. Upon troubleshooting, this issue appears to be outside of the Cetrom network. Our team promptly contacted CCH Support to investigate further.
Subscribe to Cetrom’s new Status Page for live status updates regarding our systems and many of the third-party systems you connect to: https://status.cetrom.com/
Thank you for your patience, Cetrom Support This message has been shared with your team.
Posted Apr 03, 2025 - 17:17 UTC
Identified
Update: CCH has confirmed an outage for CCH Axcess Outage. They are working on resolving this issue now.
Background: Some CCH clients are reporting slowness with CCH Axcess. Upon troubleshooting, this issue appears to be outside of the Cetrom network. Our team contacted CCH Support to investigate further.
Subscribe to Cetrom’s new Status Page for live status updates regarding our systems and many of the third-party systems you connect to: https://status.cetrom.com/
We will keep you posted as we receive updates from CCH Support regarding the CCH Axcess outage.
Thank you for your patience, Cetrom Support This message has been shared with your team.
Posted Apr 03, 2025 - 15:57 UTC
Investigating
Some CCH clients are reporting slowness with CCH Axcess. Upon troubleshooting, this issue appears to be outside of the Cetrom network. Our team has contacted CCH Support to investigate further.