Service Alert: Microsoft Reporting Widespread Service Interruptions

Incident Report for Cetrom

Resolved

Following close monitoring of the issue, Microsoft is showing all services are up and operational. This issue is now resolved.

Thank you for your patience while Microsoft worked to resolve this issue.
Cetrom Support
Posted Oct 10, 2025 - 10:19 UTC

Monitoring

Microsoft's latest update: "We've taken mitigating action to rebalance traffic to healthy infrastructure and are seeing improvement in service health. We'll continue to monitor the service environment closely."

View live Microsoft 365 reports on Downdetector: https://downdetector.com/status/microsoft-365/

Thank you,
Cetrom Support
Posted Oct 09, 2025 - 19:37 UTC

Investigating

Microsoft is reporting interruptions with several of its Microsoft 365 services. Microsoft is actively troubleshooting this issue. We will provide an update as soon as we have it.

View live widespread reports on Downdetector: https://downdetector.com/status/microsoft-365/

Thank you for your patience while Microsoft works to resolve this issue.
Cetrom Support

This message has been shared with your team.

Please share this information with your team. If email is affected, try accessing Outlook.com. If Outlook.com is unavailable, you can always access your email via Spam.cetrom.net.
Posted Oct 09, 2025 - 18:59 UTC
This incident affected: Microsoft 365 (Microsoft Applications).